[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4763: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
StompBoxZone • View topic - Boss DD-2 / DD-3 repair notes - questions and discussion

Boss DD-2 / DD-3 repair notes - questions and discussion

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby aryasridhar » Thu Sep 08, 2016 8:29 am

Hello All,

I just got a DD3 and it has a LOUD hum and there's no effect (maybe I cannot hear it), I tried using a regular wall adapter, and also tried with a battery, but it does not power on with a battery, does power on with the wall adapter, it is a regulated 9v adapter.

I cleaned up all the pots and the jacks with CRC-226, electrical contact cleaner, and have left it home for it to be absorbed and cleaned.

I also replaced the 100uf 16v filter cap next to the power supply input, it did measure right, but did it just for the sake of it with a nichicon capacitor, same value.

Also just downloaded the schematic of the DD2/3 to trace the signal once I am back home.

I am wondering, what could be the issue? the power LED sometimes is on and sometimes off, it just has a mind of its own it looks like? could it be the reverse polarity protection diode or maybe the voltage regulator?

This is a used unit i bought from someone very cheap, I did not see a single soldering/desoldering attempt anywhere on the board, so am pretty sure this has not been fiddled around with, I am unsure if the guy using the unit before me blew up the power section either. I can clearly see no repair attempts were made on this unit.

I am assuming, this could be something related to power, or grounding or the mechanical components not being in good shape, however still looking for some answers please.

This is a Made in Taiwan unit!!

Would appreciate any inputs please.
aryasridhar
New User
 
Posts: 1
Joined: Thu Sep 08, 2016 8:20 am

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby Guga Ramone » Sun Oct 23, 2016 5:20 pm

A friend of mine got a square chip DD-3 which have the repeats distorted and with a very low level, even with all the controls cranked. I swapped all the electrolitic capacitors and it got better, but still far from what the working pedal puts out. Then I remembered that when I first opened the pedal, the LED wires were cutoff (someone purposedly cut them) and I managed to fix this. Just to test, I removed one of the LED wires and now the pedal works fine! Go figure! Any clues on why this happens?
User avatar
Guga Ramone
Silver Member
 
Posts: 388
Joined: Wed Dec 07, 2011 11:02 am
Location: Curitiba - Brazil

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby sclitheroe » Tue Oct 25, 2016 2:54 pm

sclitheroe
Platinum Member
 
Posts: 1453
Joined: Fri Nov 25, 2011 2:02 pm
Location: Stoney Creek

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby Andre Borgo » Thu Jan 19, 2017 9:51 pm

Hi,
I have just pulled out my old pedals and I'm trying to get them working. As a kid I only ever used battery power and the DD-3 chewed through batteries rendering it too expensive for me. I have been doing lots of reading and have troubleshooted a few problems but now I'm stuck so assistance would be appreciated.

I have a DD-3, a CE - 2 and an OD-1. All work fine on battery. I went a bought a generic plug pack multi-volt regulated power supply outputting 600mA. I have the correct polarity and have it on 9V output. I also bought a 4 pronged adapter (not exactly a daisy chain but seems to work) to control the 3 pedals which powers the older ACA CE-2 and OD-1 however I'm getting a high pitched squeal through the DD-3 which gets louder as I turn up the volume.

I have isolated the DD-3 and tried it on the power supply on its own but still get the squeal. Considering I bought the power supply for the DD-3 it is pretty annoying. I'm guessing that the PowerTran plug pack I just bought is the problem? Do the Boss PSA plug packs eliminate this kind of interference / noise? Would like some advice before returning and buying the proper thing. Other forums had mentioned that any power supply would do (as long as requirements were met) but I'm sensing the DD-3 is a bit more temperamental. Also, I have put a battery back in the DD-3 and it works just fine with no squeal.

I have removed the DD-3, switched the multi volt output to 12V and that works fine for the CE-2 and OD-1 but I'm also wondering if that is bad since it is a regulated output? Something about the ability of these pedals to drop the voltage internally?

Any help would be appreciated.

Thanks,
Andre
Andre Borgo
New User
 
Posts: 1
Joined: Thu Jan 19, 2017 9:29 pm

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby Laurie » Fri Jan 20, 2017 1:29 am

Hi! Please see this post.

viewtopic.php?f=3&t=2833

Is your regulated supply switched mode?
User avatar
Laurie
Multi Platinum Member
BossArea Multi Platinum Member
 
Posts: 3276
Joined: Fri Nov 25, 2011 9:00 am
Location: Calgary, Canada

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby paco » Thu Mar 02, 2017 4:27 pm

Hi Laurie, i have a DD3 with the R15229875 chip. I have low level sound no matter is ON or OFF, only from the direct input i have the right sound level. I inyected 1khz signal at the output jack and sounds with nice level, but when put the signal in M5218 pin7 the sound level is poorly, otherwhise in the M5218 pin 6 and 1 the sound level is higher than the sound level of the output jack.

Do you have any idea?

Thanks very much. Paco.

Pd: Excuse me for my bad bad english, I'm from Argentina.
paco
New User
 
Posts: 1
Joined: Thu Mar 02, 2017 4:17 pm

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby keneticferret49 » Fri Jul 28, 2017 7:09 pm

I know it's quite an old post, but its the best collection of resources and I'm running out of my own ideas.
I have a blue label DD-2 which is not in perfect working order.
The delay times are all very very short but can still be changed with feedback and delay time, and the hold function doesn't work at all.

I have tested the switch in all positions, and the feedback pot removed from the circuit, and both seem to be working perfectly. Should the pot read the same values when its on the PCB as when it's off? (It maxes out at about half when in soldered to the PCB.)

It seems that the pedal is just stuck in the shortest delay time, and while the hardware of the rotary switch is testing fine, it doesnt seem to change the settings at all. Setting the rotary to Hold turns off the LED, but holding the foot switch does nothing.

I can see that when on the short setting, the switch output doesn't lead anywhere, only on M or L do lanes past the switch get a signal.

I see as well that hold uses some of the same signal paths as the longest delay time, explaining the hold not working either.

I've about used up all of my own knowledge, but any help is appreciated!
keneticferret49
New User
 
Posts: 7
Joined: Fri Jul 28, 2017 7:00 pm

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby Laurie » Fri Jul 28, 2017 8:40 pm

User avatar
Laurie
Multi Platinum Member
BossArea Multi Platinum Member
 
Posts: 3276
Joined: Fri Nov 25, 2011 9:00 am
Location: Calgary, Canada

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby keneticferret49 » Fri Jul 28, 2017 8:54 pm

keneticferret49
New User
 
Posts: 7
Joined: Fri Jul 28, 2017 7:00 pm

Re: Boss DD-2 / DD-3 repair notes - questions and discussion

Postby Laurie » Sat Jul 29, 2017 12:09 pm

Does the non-effected path work? i.e. if you use the footswitch does the pedal turn on and off?
User avatar
Laurie
Multi Platinum Member
BossArea Multi Platinum Member
 
Posts: 3276
Joined: Fri Nov 25, 2011 9:00 am
Location: Calgary, Canada

PreviousNext

Return to Technical Questions/Discussions

Who is online

Users browsing this forum: No registered users and 1 guest

cron